Batch Index du Forum
S’enregistrerRechercherFAQMembresGroupesConnexion
Répondre au sujet Page 1 sur 1
[RESOLU] probleme commande move sur xp
Auteur Message
Répondre en citant
Message [RESOLU] probleme commande move sur xp 
Bonjour,

Lorsque j'utilise ce code sur xp cela me dit que la syntaxe est incorrect alors que quand j'utilise le meme code sur seven tout fonctionne sans probleme:

Code:
MD .baba5180
MD createur_serveur_minecraft
MD commande
MD "Vos serveurs"
ping -n '5 +1' 127.0.0.1 >nul
move .baba5180 %appdata%
move createur_serveur_minecraft %appdata%\.baba5180
move "Vos serveurs" %appdata%\.baba5180\createur_serveur_minecraft
move commande %appdata%\.baba5180\createur_serveur_minecraft
pause


Merci d'avance



Dernière édition par BABA5180 le Mar 4 Sep 2012 - 14:29; édité 1 fois

______________________________________________________
Mon site =Mes programmes
Skype
Message Publicité 
PublicitéSupprimer les publicités ?


Répondre en citant
Message [RESOLU] probleme commande move sur xp 
Bonjour

%appdata% n est pas la meme chose sous seven et sous xp

sous seven : application data\roaming sous xp ce dossier n existe pas¨¨


pour connaitre les variables d envirionnement taper set puis entrer dans une fenetre de commande cmd




______________________________________________________
Faites paraitre votre batch sur BatchClipboard
Visiter le site web du posteur
Répondre en citant
Message on dirait que... 
J'ai l'impression que l'on ne peut pas utiliser les variables d'environnement pour deplacer des dossiers car je test avec la variable %ProgramFiles% (sur seven et xp ce sont les meme chemins) et sur seven cela fonctionne alors que sur xp sa ne fonctionne pas




______________________________________________________
Mon site =Mes programmes
Skype
Répondre en citant
Message [RESOLU] probleme commande move sur xp 
sous windows 7 et vista, et surement win 8, certains dossiers sont protégés afin de ne pas y faire n importe quoi.

tu as surement un message d'erreur quel est il ?
executes tu ton batch avec le clic droit : executer en tant qu'administrateur sous win 7 ?
Si non , essaie




______________________________________________________
Faites paraitre votre batch sur BatchClipboard
Visiter le site web du posteur
Répondre en citant
Message [RESOLU] probleme commande move sur xp 
Lorsque que j'utilise la commande %Appdata% de windows xp (je creer un batch sur xp qui ne voit jamais seven ou autre) pour deplacer un programme dans la dossier Application Data il me marque que la syntaxte de la commande est incorrect alors que si je marque le chemin d'acces je n'est pas ce probleme exemple:

Ne fonctionne pas:


Code:
@echo off
move wget.exe %appdata%


Fonctionne là il me deplace le fichier sans probleme:


Code:
@echo off
move wget.exe C:\"Documents and Settings"\Provignon\"Application Data"


Le probleme c'est que j'aimerais faire une chose de facon universelle qui fonctionnerait sur n'importe quel pc Windows.

Je rappel que sur windows 7 je n'ai AUCUN soucis le probleme c'est XP

Quand je fais set dans la console xp pour la variable APPDATA = C:\"Documents and Settings"\Provignon\"Application Data"




______________________________________________________
Mon site =Mes programmes
Skype
Répondre en citant
Message [RESOLU] probleme commande move sur xp 
il faut que tu détectes la version de win utilisé et que tu fasses des redirections en fonction de l os trouvé


move "%chemin%" "%chemin%" devrait fonctionner je testerai demain si j ai un peu de temps.




______________________________________________________
Faites paraitre votre batch sur BatchClipboard
Visiter le site web du posteur
Répondre en citant
Message Merci 
J'ai reussi voila le code qui fonctionne avec la variable

Code:

@echo off
move wget.exe "%appdata%"


Merci pour ton aide que tu m'a apporté c'est grâce a toi que j'ai reussi a le faire. =)




______________________________________________________
Mon site =Mes programmes
Skype
Répondre en citant
Message [RESOLU] probleme commande move sur xp 
D'ailleurs cette ligne n est pas correcte

Code:
move wget.exe C:\"Documents and Settings"\Provignon\"Application Data"



Code:
move wget.exe "C:\Documents and Settings\Provignon\Application Data"

ou avec la variable d'environnement
Code:
move wget.exe "%appdata%"

ceci devrait fonctionner aussi

Code:
move "wget.exe" "%appdata%"



Pour les versions de windows voir ce sujet http://batch.xoo.it/t1918-Test-pour-version-de-windows.htm ou celui ci
http://batch.xoo.it/t412-XP-ou-VISTA.htm




______________________________________________________
Faites paraitre votre batch sur BatchClipboard
Visiter le site web du posteur
Répondre en citant
Message ca fonctiinne 
c est bon tout fonctionne merci Laddy de ton aide




______________________________________________________
Mon site =Mes programmes
Skype
Message [RESOLU] probleme commande move sur xp 


Montrer les messages depuis:
Répondre au sujet Page 1 sur 1
  



Index | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Copyright 2008 - 2016 // Batch