Batch Index du Forum
S’enregistrerRechercherFAQMembresGroupesConnexion
Répondre au sujet Page 1 sur 1
Lièvre_Tortue
Auteur Message
Répondre en citant
Message Lièvre_Tortue 
Hello!
Voici un petit algorithme Lièvre_Tortue que j'ai réécris en Batch.
Je poste l'original et ma version en Batch.

Présentation de l'algorithme:

Règle du jeu : À chaque tour, on lance un dé. Si le 6 sort, alors le lièvre gagne la partie, sinon la tortue avance d’une case. La tortue gagne quand elle a avancé 6 fois.

Algorithme Original (AlgoBox):

Code:
     VARIABLES
       face_du_de EST_DU_TYPE NOMBRE
       case_tortue EST_DU_TYPE NOMBRE
     DEBUT_ALGORITHME
       case_tortue PREND_LA_VALEUR 0
       face_du_de PREND_LA_VALEUR 0
       TANT_QUE (face_du_de<6 ET case_tortue<6) FAIRE
         DEBUT_TANT_QUE
         //Le jeu continue : on lance le dé
        face_du_de PREND_LA_VALEUR floor(6*random()+1)
        AFFICHER "Le dé donne un "
        AFFICHER face_du_de
        SI (face_du_de<6) ALORS
          DEBUT_SI
          //La tortue avance d'une case
          case_tortue PREND_LA_VALEUR case_tortue+1
          AFFICHER " -> la tortue passe à la case "
          AFFICHER case_tortue
          FIN_SI
        FIN_TANT_QUE
      SI (case_tortue==6) ALORS
        DEBUT_SI
        AFFICHER "La tortue gagne"
        FIN_SI
        SINON
          DEBUT_SINON
          AFFICHER " -> le lièvre gagne"
          FIN_SINON
    FIN_ALGORITHME


Algorithme en Batch:

Code:
@Echo Off
Title Lievre_Tortue
Echo ***Algorithme lance***
Echo.
Set/A Case_Tortue= 0
Set/A Face_Du_De= 0
:Debut_Tant_Que
Set/A Face_Du_De= "%Random%%%7"
If "%Face_Du_De%" Lss "6" Goto Debut_Si
If "%Face_Du_De%" Equ "6" Goto Fin_Si
:Debut_Si
Set/A Case_Tortue= "%Case_Tortue%"+"1"
Echo Le de donne un %Face_Du_De% - La tortue passe a la casse %Case_Tortue%.
If "%Case_Tortue%" Equ "6" Goto Fin_Tant_Que
Goto Debut_Tant_Que
:Fin_Si
Echo Le de donne un %Face_Du_De% - Le lievre gagne.
Echo.
Echo ***Algorithme termine***
Pause>Nul
Exit
:Fin_Tant_Que
Echo Le de donne un %Face_Du_De% - La tortue gagne.
Echo.
Echo ***Algorithme termine***
Pause>Nul
Exit


Cordialement.

PS: On dit un algorithme ou une algorithme?




______________________________________________________
Viens découvrir INTERPOL, un nouveau langage interprété !

Yahoo Messenger
Message Publicité 
PublicitéSupprimer les publicités ?


Répondre en citant
Message Lièvre_Tortue 
Salut Mr. Green

intéressant tout ça, je connais AlgoBox, je l'utilise beaucoup au lycée.. Wink

J'ai regardé vite fais et il me semble que le code est réductible.. Mais bien codé, propre.. Okay

@++




______________________________________________________
│Øδ@π.
Visiter le site web du posteur Skype
Répondre en citant
Message Lièvre_Tortue 
Yo,
Code propre et lisible Wink
Ton programme m'a l'air sympa ^^
Et pour info, on dit un algorithme.
Sur ce,
@_+




______________________________________________________
Skype
Répondre en citant
Message Lièvre_Tortue 
Ok, Merci Wink




______________________________________________________
Viens découvrir INTERPOL, un nouveau langage interprété !

Yahoo Messenger
Message Lièvre_Tortue 


Montrer les messages depuis:
Répondre au sujet Page 1 sur 1
  



Index | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Copyright 2008 - 2016 // Batch