Batch Index du Forum
S’enregistrerRechercherFAQMembresGroupesConnexion
Répondre au sujet Page 2 sur 2
Aller à la page: <  1, 2
[R] ca ne Ping pas fort
Auteur Message
Répondre en citant
Message [R] ca ne Ping pas fort 
Revue du message précédent :

Voilà le code corrigé :
Code:

@echo off
setlocal ENABLEDELAYEDEXPANSION
 
set log=C:\util\licxp.log
set w7=C:\util\ac27.txt
SET _source=C:\util
set _destw7=C$\ProgramData\SolidWorks
 
echo;Parametres :
echo;ÄÄÄÄÄÄÄÄÄÄÄÄÄ
echo;
for %%A in ("log" "w7" "_source" "_destw7") do (
   if exist "!%%~A!" (echo;%%~A = !%%~A! - Existe = oui) else (
      echo;%%~A = !%%~A! - Existe = non ^(peut g‚ner‚ des erreurs^)
      )
)
 
(
echo;
echo;%DATE%)>> %log%
 
for /f %%i in (%w7%) do (
  rem Suppression du FIND pour trouver si il y a un résultat, je pense que tu voulais
  rem simplement vérifier si la machine est allumée, donc && suffit ^^
   ping -n 1 %%i&&(robocopy "%_source%"  "\\%%i\%_destw7%"  "SolidWorksStandaloneLic.lic" /R:1 /W:1  "/LOG+:%log%")
   if "!errorlevel!" EQU "0" (echo;Copie effectu‚e) else (
      echo;Erreur num‚ro !errorlevel! lors de la copie de %_source%\SolidWorksStandaloneLic.lic vers \\%%i\%_destw7%
      )
)
pause>NUL


Apparemment le chemin d'accès réseau est faut, est-tu sûr qu'il existe ? Qu'il n'y a pas une faute ?

Je ne vois que cette explication, ou bien une mauvaise utilisation de la commande robocopy mais j'ai déjà vérifier et c'est correct !

@ ++ Okay Wink

Visiter le site web du posteur Skype
Message Publicité 
PublicitéSupprimer les publicités ?


Répondre en citant
Message [R] ca ne Ping pas fort 
Code:
R


Maintenant, cela fonctionne parfaitement !

Pour tenir compte de la réponse du contrôleur de domaine j'ai modifié la ligne ci dessous :
Code:
for /f %%i in (%w7%) do (
   ping -n 1 %%i|find /I "Impossible" &&(echo Echec de la copie de %%i>> %log%)||(robocopy "%_source%"  "\\%%i\%_destw7%"  "SolidWorksStandaloneLic.lic" /R:1 /W:1  "/LOG+:%log%")


Le code s'exécute rapidement. Je vais pourvoir utiliser cette boucle pour d'autres...aventures.. Laughing

Encore merci pour ton aide Xenosis Okay (sans oublier tsnake41)

Félix Lechat.




______________________________________________________
"La plus grande gloire n'est pas de ne jamais tomber, mais de se relever à chaque chute." N.Mandela
Répondre en citant
Message [R] ca ne Ping pas fort 
Pas de soucis Wink

Par contre le [R] doit se placer sur ton premier post (donc tu l'edit) et tu modifie le "Sujet" en ajoutant [R] au début, donc ça devrait faire :

"[R] ça ne Ping pas fort"

Voilà @ ++ Okay Wink




______________________________________________________
Coucou, tu veux voir mon Site Web ?? Mort de Rire
Visiter le site web du posteur Skype
Message [R] ca ne Ping pas fort 


Montrer les messages depuis:
Répondre au sujet Page 2 sur 2
Aller à la page: <  1, 2
  



Index | créer un forum | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Copyright 2008 - 2016 // Batch